code prole

Icon

coding for the proletariat since 1977

MyEclipse 3.8.4 Beta for 3.1M6

Recently I upgraded from the milestone 5 build of Eclipse 3.1 to milestone 6. Afterwards I reinstalled MyEclipse only to discover I’d lost some functionality. The XML editor no longer seemed to function but I could open Ant build scripts via the Ant editor. Just to add spice, the Ant run option was missing from the Run menu. Very odd indeed.

One of the cool things about MyEclipse is that it is a subscription service as well as the best J2EE plugin suite for Eclipse. Visiting the forums at MyEclipse I was able to find explanations and work around techniques for both situations.

The XML editor problem was solved by removing the “links” folder from my Eclipse installation. The only entry in this folder pointed to the MyEclipse installation elsewhere in my file system. Even though I had re-installed MyEclipse, this linkage wasn’t operating correctly. Removing (or just renaming) the links folder and installed MyEclipse once again resulting in a work XML editor.

The Ant build script problem is really just a case of a missing menu item. The functionality is still included. Using the Option-Shift-X keystroke combination on Mac OS X (Alt-Shift-X on Windows) gives me a popup menu that list several run choices. Selecting “Q” runs the currently selected build.xml file in Ant. Nice.

Like many others I am eagerly awaiting the release later this week of Version 4.0 of MyEclipse which includes UML modeling among other enhancements. With just a couple of months of full-time MyEclipse use under by belt I must say I am very impressed. If the UML functionality is up to their already high standard, I will be very pleased.

Advertisements

Filed under: MyEclipse